# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)(?<=,|^)(?:(?!\b(?:city|disc?trict|street|plaza|square|tower|block|mansion|garden|house|building)\b)[^,])*(?=,|$)//gm;t' <<< "big fake plaza, 12 this street, district, city
Green mansion, district, city
Block 7c of orange building district, city
98 main street block a blue plaza, city
tower 10, caribbean coast, district
block 3a, the latitude, city
blue red mansion, 46 pearl street, city
dorsett hotel, city
block 9, Willowland, disctrict, city
tower 2, the coronation, 1 fake street, district
"