const regex = /(?i)(?<=,|^)(?:(?!\b(?:city|disc?trict|street|plaza|square|tower|block|mansion|garden|house|building)\b)[^,])*(?=,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?<=,|^)(?:(?!\\b(?:city|disc?trict|street|plaza|square|tower|block|mansion|garden|house|building)\\b)[^,])*(?=,|$)', 'gm')
const str = `big fake plaza, 12 this street, district, city
Green mansion, district, city
Block 7c of orange building district, city
98 main street block a blue plaza, city
tower 10, caribbean coast, district
block 3a, the latitude, city
blue red mansion, 46 pearl street, city
dorsett hotel, city
block 9, Willowland, disctrict, city
tower 2, the coronation, 1 fake street, district
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);