use strict;
my $str = '## mentions
[]';
my $regex = qr/.*\n(?=\[\])/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";