$re = '/.*\n(?=\[\])/m';
$str = '## mentions
[]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;