using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<prefix>((?:(?!<optTag.*?>).)*?)(<optTag.*?>)?((?:(?!<optTag.*?>).)*?)<postfix>$";
string input = @"<prefix>some chars<optTag value>some chars<postfix>
<prefix><optTag value>some chars<postfix>
<prefix>some chars<optTag value><postfix>
<prefix><optTag value><postfix>
<prefix><postfix>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}