$re = '/^<prefix>((?:(?!<optTag.*?>).)*?)(<optTag.*?>)?((?:(?!<optTag.*?>).)*?)<postfix>$/m';
$str = '<prefix>some chars<optTag value>some chars<postfix>
<prefix><optTag value>some chars<postfix>
<prefix>some chars<optTag value><postfix>
<prefix><optTag value><postfix>
<prefix><postfix>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);