package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<table><table border="0" cellpadding="0" cellspacing="0" align="left" style="width:100%;border-top:3px solid #7342e8">[\w\W]*?<\/table>)`)
var str = `<table border="0" cellpadding="0" cellspacing="0" align="left" style="width:100%;border-top:3px solid #7342e8">
<tbody><tr>
<td width="90" height="43" style="padding-left:14px;border-bottom:1px solid #ebebeb;background-color:#f6f6f6;font-family:'\00b098\00b214\00ace0\00b515',NanumGothic,'\00b9d1\00c740\00ace0\00b515',Malgun Gothic,'\00b3cb\00c6c0',Dotum,Helvetica,'Apple SD Gothic Neo',Sans-serif;font-size:13px;color:#696969">space</td>
</tbody></table>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}