const regex = /(?<table><table border="0" cellpadding="0" cellspacing="0" align="left" style="width:100%;border-top:3px solid #7342e8">[\w\W]*?<\/table>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<table><table border="0" cellpadding="0" cellspacing="0" align="left" style="width:100%;border-top:3px solid #7342e8">[\\w\\W]*?<\\\/table>)', 'g')
const str = `<table border="0" cellpadding="0" cellspacing="0" align="left" style="width:100%;border-top:3px solid #7342e8">
<tbody><tr>
<td width="90" height="43" style="padding-left:14px;border-bottom:1px solid #ebebeb;background-color:#f6f6f6;font-family:'\\00b098\\00b214\\00ace0\\00b515',NanumGothic,'\\00b9d1\\00c740\\00ace0\\00b515',Malgun Gothic,'\\00b3cb\\00c6c0',Dotum,Helvetica,'Apple SD Gothic Neo',Sans-serif;font-size:13px;color:#696969">space</td>
</tbody></table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}