using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(\s\w{3}\s\d{2}\s))[-\d].+|(?<=)\d+$";
string input = @"Revenue as of Mar 19 12200
Revenue as of end of quarter 12200
Revenue as of Mar 19 12200 -
Revenue as of Mar 19 - 12200
Revenue as of Mar 19 12,200 5,000
Revenue as of Mar 19 12,200 5,000 6,000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}