re = /(?<=(\s\w{3}\s\d{2}\s))[-\d].+|(?<=)\d+$/m
str = 'Revenue as of Mar 19 12200
Revenue as of end of quarter 12200
Revenue as of Mar 19 12200 -
Revenue as of Mar 19 - 12200
Revenue as of Mar 19 12,200 5,000
Revenue as of Mar 19 12,200 5,000 6,000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end