$re = '%[a-zA-Z0-9_-]+\.html$%';
$str = 'https://example.com.ua/part1/part2/part3/product-123.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);