re = /[a-zA-Z0-9_-]+\.html$/
str = 'https://example.com.ua/part1/part2/part3/product-123.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end