import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\s*;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?\\s*(?:;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?(?:\\s*;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?)*)?\\s*(?:\\((?:;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?(?:\\s*;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?)*)?\\)(?:\\((?:;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?(?:\\s*;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?)*)?\\))*)?\\s*\\)";
final String string = "(;GM[1]FF[4]CA[UTF-8]AP[Sabaki:0.52.2]KM[6.5]SZ[19]DT[2023-12-25];B[pd];W[dd];B[pq];W[dp])\n\n"
+ "(;GM[1]FF[4]CA[UTF-8]AP[Sabaki:0.52.2]KM[6.5]SZ[19]DT[2023-12-25];B[pd];W[dd](;B[pq];W[dp])(;B[dp];W[pp]))\n\n"
+ "(;GM[1]FF[4]CA[UTF-8]AP[Sabaki:0.52.2]KM[6.5]SZ[19]DT[2023-12-25];B[pd];W[dd](;B[pq];W[dp])(;B[dp];W[pp];PL[B]AE[jk]AB[jj]AW[ji];B[jq]))\n\n"
+ "(;GM[1]FF[4]CA[UTF-8]AP[Sabaki:0.52.2]KM[6.5]SZ[19]DT[2023-12-25];B[pd]C[Comment on move.];W[dd](;B[pq];W[dp])(;B[dp];W[pp];PL[B]AE[jk]AB[jj]AW[ji]C[Comment on editing.];B[jq]))";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}