using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:^'(?=.*'$)|(?=^[^']+$))[a-z]'?$";
string input = @"hello
one letter below
a
another letter below, but signle quoted
'a'
a'
'a
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}