$re = '/^(?:^\'(?=.*\'$)|(?=^[^\']+$))[a-z]\'?$/m';
$str = 'hello
one letter below
a
another letter below, but signle quoted
\'a\'
a\'
\'a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);