import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\d\\d[2468][048]|\\d\\d[13579][26]|\\d\\d0[48]|[02468][048]00|[13579][26]00)-02-29|\\d{4}-((0[13578]|1[02])-(0[1-9]|[12]\\d|3[01])|(0[469]|11)-(0[1-9]|[12]\\d|30)|(02)-(0[1-9]|1\\d|2[0-8])))T([01]\\d|2[0-3]):[0-5]\\d:[0-5]\\d\\.\\d{3}([+-]([01]\\d|2[0-3]):[0-5]\\d|Z)$";
final String string = "2023-02-28T00:00:00.000Z\n"
+ "2023-02-29T00:00:00.000Z\n"
+ "2024-02-29T00:00:00.000Z\n"
+ "2023-06-30T00:00:00.000Z\n"
+ "2023-06-31T00:00:00.000Z\n"
+ "2023-07-31T00:00:00.000Z\n\n"
+ "2023-07-31T00:00:00.000-05:30\n\n"
+ "2023-07-31T00:59:59.000Z\n"
+ "2023-07-31T00:60:59.000Z\n"
+ "2023-07-31T00:59:60.000Z";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}