package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\\[^\\]*){3}$`)
var str = `D:\repos\my-repo\some\script\path.ps1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}