$re = '/(?:\\\\[^\\\\]*){3}$/m';
$str = 'D:\\repos\\my-repo\\some\\script\\path.ps1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);