$re = '/((\d*(?:,?\.?)\d*(?:,?\.?))\s?\/\s?(\d*(?:,?\.?)\d*(?:,?\.?)))(?!\s?x)/m';
$str = 'dummy word 222/2334; Ø14 x Ø6,33/523,23 x 2311 mm
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);