package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\(\$(\w+)\).*`)
var str = `#Lorem ipsum
foo bar baz ($BLAH) is lorem ipsum
Learn more about #BLAH`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}