$re = '/.*\(\$(\w+)\).*/m';
$str = '#Lorem ipsum
foo bar baz ($BLAH) is lorem ipsum
Learn more about #BLAH';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);