package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[_.][0-9]+[a-zA-Z]*_{0,1}$`)
var str = `_0898989811abced_`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}