using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"TM_(?:TASK|CHECKLIST)";
string input = @"TM_TASK and TM_CHECKLIST is present";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}