$re = '/TM_(?:TASK|CHECKLIST)/';
$str = 'TM_TASK and TM_CHECKLIST is present';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);