# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[\+ 0]0?937 \d{3} \d{4}$//sgm;t' <<< "00937 878 1536
+937 878 1536"