import re
regex = re.compile(r"\\.+?(?= \|)", flags=re.IGNORECASE)
test_str = ("| Area | vserver | file-id |connection-id | session-id | open-mode | path |\n"
"| manphsan01 | manphs101 | 9980 | 4278018043 | 5065142205921760710 | rw | Share01\\Mandaue\\Data01 |\n"
"| manphsan01 | manphs101 | 1790 | 4278020659 | 5065142205921763223 | rwd | FinanceDept\\ARCHIVING |\n"
"| manphsan01 | manphs101 | 1824 | 4278020659 | 5065142205921763223 | rwd | Share01\\Cebu\\Year2022 |\n"
"| manphsan01 | manphs101 | 1976 | 4278020659 | 5065142205921763223 | rwd | SGSDept\\General\\Document | more |\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)