package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/animals(?:/(?P<id>\d+))?`)
var str = `/animals/10
/animals`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}