$re = '%/animals(?:/(?P<id>\d+))?%';
$str = '/animals/10
/animals';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);