#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\d.]+\/\d\d\S*"
Local $sString = "0.0.0.0/0 *[OSPF/150] 5w2d 19:06:26, metric 24, tag 100" & @CRLF & _
" to 10.239.248.129 via ae101.0" & @CRLF & _
" > to 10.239.248.137 via ae102.0" & @CRLF & _
"1.1.21.0/30 *[OSPF/10] 5w2d 19:06:26, metric 23" & @CRLF & _
" > to 10.239.248.129 via ae101.0" & @CRLF & _
" to 10.239.248.137 via ae102.0" & @CRLF & _
" [BGP/170] 10w3d 08:00:01, localpref 260, from 189.40.251.20" & @CRLF & _
" AS path: 17379 I, validation-state: unverified" & @CRLF & _
" > to 10.239.248.129 via ae101.0, Push 16151" & @CRLF & _
" to 10.239.248.137 via ae102.0, Push 16109" & @CRLF & _
" [BGP/170] 10w3d 08:00:54, localpref 260, from 189.40.251.21" & @CRLF & _
" AS path: 17379 I, validation-state: unverified" & @CRLF & _
" > to 10.239.248.129 via ae101.0, Push 16151" & @CRLF & _
" to 10.239.248.137 via ae102.0, Push 16109" & @CRLF & _
"1.1.21.4/30 *[OSPF/10] 5w2d 19:06:26, metric 23" & @CRLF & _
" to 10.239.248.129 via ae101.0" & @CRLF & _
" > to 10.239.248.137 via ae102.0" & @CRLF & _
" [BGP/170] 10w3d 07:57:12, MED 120, localpref 100, from 189.40.251.21" & @CRLF & _
" AS path: ?, validation-state: unverified" & @CRLF & _
" > to 10.239.248.129 via ae101.0" & @CRLF & _
" [BGP/170] 10w3d 07:56:39, MED 120, localpref 100, from 189.40.251.20" & @CRLF & _
" AS path: ?, validation-state: unverified" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")