import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\d.]+\\/\\d\\d\\S*";
final String string = "0.0.0.0/0 *[OSPF/150] 5w2d 19:06:26, metric 24, tag 100\n"
+ " to 10.239.248.129 via ae101.0\n"
+ " > to 10.239.248.137 via ae102.0\n"
+ "1.1.21.0/30 *[OSPF/10] 5w2d 19:06:26, metric 23\n"
+ " > to 10.239.248.129 via ae101.0\n"
+ " to 10.239.248.137 via ae102.0\n"
+ " [BGP/170] 10w3d 08:00:01, localpref 260, from 189.40.251.20\n"
+ " AS path: 17379 I, validation-state: unverified\n"
+ " > to 10.239.248.129 via ae101.0, Push 16151\n"
+ " to 10.239.248.137 via ae102.0, Push 16109\n"
+ " [BGP/170] 10w3d 08:00:54, localpref 260, from 189.40.251.21\n"
+ " AS path: 17379 I, validation-state: unverified\n"
+ " > to 10.239.248.129 via ae101.0, Push 16151\n"
+ " to 10.239.248.137 via ae102.0, Push 16109\n"
+ "1.1.21.4/30 *[OSPF/10] 5w2d 19:06:26, metric 23\n"
+ " to 10.239.248.129 via ae101.0\n"
+ " > to 10.239.248.137 via ae102.0\n"
+ " [BGP/170] 10w3d 07:57:12, MED 120, localpref 100, from 189.40.251.21\n"
+ " AS path: ?, validation-state: unverified\n"
+ " > to 10.239.248.129 via ae101.0\n"
+ " [BGP/170] 10w3d 07:56:39, MED 120, localpref 100, from 189.40.251.20\n"
+ " AS path: ?, validation-state: unverified\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}