package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^/]+/[0-9a-f]{8}-[0-9a-f]{4}-4[0-9a-f]{3}-[89ab][0-9a-f]{3}-[0-9a-f]{12}$`)
var str = `test/00b46e01-3994-4ac2-939e-2d5052a65961
anotherword/58628d3f-becf-4f54-bdea-336ca9247145`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}