$re = '~^[^/]+/[0-9a-f]{8}-[0-9a-f]{4}-4[0-9a-f]{3}-[89ab][0-9a-f]{3}-[0-9a-f]{12}$~m';
$str = 'test/00b46e01-3994-4ac2-939e-2d5052a65961
anotherword/58628d3f-becf-4f54-bdea-336ca9247145';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);