package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(?:;|\{|\||\|\||&|&&|\n|\r|`)\s*[\(,@\'\"\s]*(?:[\w'\"\.\/]+\/|[\\\\'\"\^]*\w[\\\\'\"\^]*:.*\\\\|[\^\.\w '\"\/\\\\]*\\\\)?[\"\^]*(?:\.[\"\^]*\w+)?\b`)
var str = `127.0.0.1 & shutdown /l`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}