$re = '/(?i)(?:;|\{|\||\|\||&|&&|\n|\r|`)\s*[\(,@\'\"\s]*(?:[\w\'\"\.\/]+\/|[\\\\\\\\\'\"\^]*\w[\\\\\\\\\'\"\^]*:.*\\\\\\\\|[\^\.\w \'\"\/\\\\\\\\]*\\\\\\\\)?[\"\^]*(?:\.[\"\^]*\w+)?\b/m';
$str = '127.0.0.1 & shutdown /l';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);