#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\w{1}_{1}\w{1}_{1}\w{1}_{1}\w{1}_{1})\w{1}"
Local $sString = "a_a_a_a_a" & @CRLF & _
"a_a_b_a_a" & @CRLF & _
"a_a_a_a_f" & @CRLF & _
"a_a_a_a_a" & @CRLF & _
"a_a_a_a_a" & @CRLF & _
"a_a_c_a_a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")