$re = '/(?<=\w{1}_{1}\w{1}_{1}\w{1}_{1}\w{1}_{1})\w{1}/m';
$str = 'a_a_a_a_a
a_a_b_a_a
a_a_a_a_f
a_a_a_a_a
a_a_a_a_a
a_a_c_a_a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);