#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(.+\w)(?=\1+)"
Local $sString = "123123123123" & @CRLF & _
"daddaddaddad" & @CRLF & _
"sadsadasad" & @CRLF & _
"sadsadsad" & @CRLF & _
"121212121" & @CRLF & _
"sasasasasas" & @CRLF & _
"sdsdsdsds" & @CRLF & _
"dsdsdsdsd" & @CRLF & _
"ffffffff" & @CRLF & _
"blahblah" & @CRLF & _
"ioiooioioioi" & @CRLF & _
"popopopopop" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Hi I dont think this is a spam." & @CRLF & _
"II loooovve this. It's awesooooommeee!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")