# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.+\w)(?=\1+)"
test_str = ("123123123123\n"
"daddaddaddad\n"
"sadsadasad\n"
"sadsadsad\n"
"121212121\n"
"sasasasasas\n"
"sdsdsdsds\n"
"dsdsdsdsd\n"
"ffffffff\n"
"blahblah\n"
"ioiooioioioi\n"
"popopopopop\n\n\n"
"Hi I dont think this is a spam.\n"
"II loooovve this. It's awesooooommeee!")
matches = re.finditer(regex, test_str, re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.