import re
regex = re.compile(r"^[CM]", flags=re.MULTILINE)
test_str = ("Tokyo\n"
"Jakarta\n"
"Delhi\n"
"Mumbai\n"
"Manila\n"
"Shanghai\n"
"Sao Paulo\n"
"Seoul\n"
"Mexico City\n"
"Guangzhou\n"
"Beijing\n"
"Cairo\n"
"New York\n"
"Kolkata\n"
"Moscow\n"
"Bangkok\n"
"Buenos Aires\n"
"Shenzhen\n"
"Dhaka\n"
"Lagos")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")