import re
regex = re.compile(r"^[A-Z][a-z\'\s]+:[A-Z\s]+$", flags=re.MULTILINE)
test_str = ("Eminem:VENOM\n"
"Linkin park:NUMB\n"
"Drake:NONSTOP\n"
"Adele:HELLO\n"
"Michael Jackson:ANOTHER PART OF ME\n"
"Adele:ONE AND ONLY\n"
"Guns n'roses:NOVEMBER RAIN\n"
"Christina Aguilera: HuRt\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")