$re = '/^\.\/.*$(?<!\/)/m';
$str = './Dockerfile
./Dockerfiles/Dockerfile
./Dockerfiles/prod/Dockerfile
./Dockerfile/
./Dockerfiles/Dockerfile/
./Dockerfiles/prod/Dockerfile/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);