re = /^\.\/.*$(?<!\/)/m
str = './Dockerfile
./Dockerfiles/Dockerfile
./Dockerfiles/prod/Dockerfile
./Dockerfile/
./Dockerfiles/Dockerfile/
./Dockerfiles/prod/Dockerfile/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end