package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+`)
var str = `Что такое Creative Cloud?
Объяснить это можно в 5 строках:
Creative Cloud — это коллекция из более чем 30 приложений и сервисов для работы с фотографиями, видео, веб-контентом, дизайна, разработки интерфейсов на ПК и мобильных устройствах. Встроенные руководства и шаблоны помогут начать работу. Будь вы новичок или профессионал — у вас появится всё, чтобы реализовать любые идеи.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}