# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d+"
test_str = ("Что такое Creative Cloud?\n"
"Объяснить это можно в 5 строках:\n"
"Creative Cloud — это коллекция из более чем 30 приложений и сервисов для работы с фотографиями, видео, веб-контентом, дизайна, разработки интерфейсов на ПК и мобильных устройствах. Встроенные руководства и шаблоны помогут начать работу. Будь вы новичок или профессионал — у вас появится всё, чтобы реализовать любые идеи.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.