$re = '/\b\d*[^\W\d_][^\W_]*\b/m';
$str = 'win32 backdoor guid:64664646 DNS-lookup h0lla 1234 12.356';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;