re = /\b\d*[^\W\d_][^\W_]*\b/m
str = 'win32 backdoor guid:64664646 DNS-lookup h0lla 1234 12.356'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result