use strict;
my $str = 'https://pii.ngkf-qa.commloanservices.com:5999/qa2                                                                                                                                                                 
https://pii.ngkf-qa.pncint.net/qa1                                                                                                                                                                           
https://pii.ngkf-qa.pncint.net/qa2                                                                                                                                                                           
https://pii.rait.commloanservices.com/PII                                                                                                                                                                    
https://pii.rait.pncint.net/PII                                                                                                                                                                              
https://pii.rait-qa.commloanservices.com/qa1                                                                                                                                                                 
https://pii.rait-qa.pncint.net/qa1                                                                                                                                                                           
https://pii.situs.commloanservices.com/PII                                                                                                                                                                   
https://pii.situs.pncint.net/PII                                                                                                                                                                             
https://pii.situs-qa.commloanservices.com/qa1                                                                                                                                                                
https://pii.situs-qa.commloanservices.com/qa2                                                                                                                                                                
https://pii.situs-qa.pncint.net/qa1                                                                                                                                                                          
https://pii.situs-qa.pncint.net/qa2                                                                                                                                                                          
https://pii.situs-rnd.pncint.net/dev1                                                                                                                                                                        
https://pii.situs-rnd.pncint.net/dev2                                                                                                                                                                        
https://pii.situs-uat.pncint.net/test1                                                                                                                                                                       
https://pii.situs-uat.pncint.net/test2                                                                                                                                                                       
https://pii.suntrust.commloanservices.com/PII                                                                                                                                                                
https://pii.suntrust.pncint.net/pii                                                                                                                                                                          
https://pii.suntrust-qa.commloanservices.com/qa1                                                                                                                                                             
https://pii.suntrust-qa.commloanservices.com/qa2                                                                                                                                                             
https://pii.suntrust-qa.pncint.net/qa1                                                                                                                                                                       
https://pii.suntrust-qa.pncint.net/qa2                                                                                                                                                                       
https://pii.wd.commloanservices.com/PII                                                                                                                                                                      
https://pii.wd.pncint.net/pii                                                                                                                                                                                
https://pii.wd-qa.commloanservices.com/qa1                                                                                                                                                                   
https://pii.wd-qa.commloanservices.com/qa2                                                                                                                                                                   
https://pii.wd-qa.pncint.net/qa1                                                                                                                                                                             
https://pii.wd-qa.pncint.net/qa2                                                                                                                                                                             
https://rdt.midlandls.pncint.net/pnclms                                                                                                                                                                      
https://rdt.midlandls-qa.pncint.net/pnclms                                                                                                                                                                   
https://tci-pnc.pncint.net/                                                                                                                                                                                  
https://tci-pnc-qa-pncint.net/                                                                                                                                                                               
https://tci-pnc-rnd.pncint.net/                                                                                                                                                                              
https://tci-pnc-uat.pncint.net/                                                                                                                                                                              
https://wlm.midlandls.pncint.net/                                                                                                                                                                            
https://wlm.midlandls-qa.pncint.net/qa1                                                                                                                                                                      
https://wlm.midlandls-qa.pncint.net/qa2                                                                                                                                                                      
https://wlm-app.midlandls-qa.pncint.net/qa1-fdic                                                                                                                                                             
https://wlm-app.midlandls-qa.pncint.net/qa2fdic   ';
my $regex = qr/^(?:(?<protocol>\w*?):\/\/(?<authority>(?<mnemonic>\w*).(?<host>(?<clientid>(?<client>\w*)-?(?<environment>\w*)).(?<domain>[\w-.]*))(?::?(?<port>\d*)))\/(?<path>[\w-]*)\s*$)/mp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}