import Foundation
let pattern = #"^(?:(?<protocol>\w*?):\/\/(?<authority>(?<mnemonic>\w*).(?<host>(?<clientid>(?<client>\w*)-?(?<environment>\w*)).(?<domain>[\w-.]*))(?::?(?<port>\d*)))\/(?<path>[\w-]*)\s*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://pii.ngkf-qa.commloanservices.com:5999/qa2
https://pii.ngkf-qa.pncint.net/qa1
https://pii.ngkf-qa.pncint.net/qa2
https://pii.rait.commloanservices.com/PII
https://pii.rait.pncint.net/PII
https://pii.rait-qa.commloanservices.com/qa1
https://pii.rait-qa.pncint.net/qa1
https://pii.situs.commloanservices.com/PII
https://pii.situs.pncint.net/PII
https://pii.situs-qa.commloanservices.com/qa1
https://pii.situs-qa.commloanservices.com/qa2
https://pii.situs-qa.pncint.net/qa1
https://pii.situs-qa.pncint.net/qa2
https://pii.situs-rnd.pncint.net/dev1
https://pii.situs-rnd.pncint.net/dev2
https://pii.situs-uat.pncint.net/test1
https://pii.situs-uat.pncint.net/test2
https://pii.suntrust.commloanservices.com/PII
https://pii.suntrust.pncint.net/pii
https://pii.suntrust-qa.commloanservices.com/qa1
https://pii.suntrust-qa.commloanservices.com/qa2
https://pii.suntrust-qa.pncint.net/qa1
https://pii.suntrust-qa.pncint.net/qa2
https://pii.wd.commloanservices.com/PII
https://pii.wd.pncint.net/pii
https://pii.wd-qa.commloanservices.com/qa1
https://pii.wd-qa.commloanservices.com/qa2
https://pii.wd-qa.pncint.net/qa1
https://pii.wd-qa.pncint.net/qa2
https://rdt.midlandls.pncint.net/pnclms
https://rdt.midlandls-qa.pncint.net/pnclms
https://tci-pnc.pncint.net/
https://tci-pnc-qa-pncint.net/
https://tci-pnc-rnd.pncint.net/
https://tci-pnc-uat.pncint.net/
https://wlm.midlandls.pncint.net/
https://wlm.midlandls-qa.pncint.net/qa1
https://wlm.midlandls-qa.pncint.net/qa2
https://wlm-app.midlandls-qa.pncint.net/qa1-fdic
https://wlm-app.midlandls-qa.pncint.net/qa2fdic
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)