package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9a-f]{8}-[0-9a-f]{4}-[1-5][0-9a-f]{3}-[89ab][0-9a-f]{3}-[0-9a-f]{12}`)
var str = `something-rows-1973912739821738172-25892e17-80f6-415f-9c65-7395632f0223`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}