re = /[0-9a-f]{8}-[0-9a-f]{4}-[1-5][0-9a-f]{3}-[89ab][0-9a-f]{3}-[0-9a-f]{12}/
str = 'something-rows-1973912739821738172-25892e17-80f6-415f-9c65-7395632f0223'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end